SMF - Just Installed!

Main Menu

Problems uploading software

Started by Piombo, March 16, 2016, 12:44:18 PM

Previous topic - Next topic


Hi i'm currently trying to upload another software into my ATM. I've tried with almost every version of arduino(1.6.1/1.6.4/1.6.5/1.6.8...) and with any of the software (cyclotron, odytron, etc..) I follow the instructions, copy the code source in documents/arduino and the library into documents/arudino/libraries. I tryed as well with the two version of libraries i found in discussions here on the forum (if you go on download page the file is only the standalone application for the librarian editor) one consisting of two folders, the other one (called libraries 2.3) consisting of various folders. I tried litterally every different combination but the result is always the same: arduino will almost finish the upload and than an error message would come out:
Arduino: 1.6.1 (Windows 8.1), Board: "Arduino Uno"
Sketch uses 21,220 bytes (65%) of program storage space. Maximum is 32,256 bytes.
Global variables use 1,454 bytes (70%) of dynamic memory, leaving 594 bytes for local variables. Maximum is 2,048 bytes.
avrdude: ser_open(): can't open device "\\.\COM1": The system cannot find the file specified.
Problem uploading to board.  See for suggestions.

  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.     WHAT AM I DOING WRONG????


ALSO I reinstalled the ftdi cable drivers thinking that could have been a problem there, but again nothing to do


The libraries and software look like they are installed OK.  V1.6.5 is the one to go for.  I can't find the COMM port for the FTDI cable.

  • Have you selected the FTDI cable from the Tools->Ports menu in the arduino software.  It is normally the bottom option that you have to select
    Have you switched the black switch on the Atmegatron to the left (when viewed from above, or to the right when viewed from the back)? Switch it back an forth a couple of times.  Sometimes it doesn't travel the full distance and doesn't switch fully.


The port wasn't selected in arduino!!! thanks a lot it uploaded perfectly now!!!