Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - rio

Pages: [1]
1
Fault report / Defective LED in LED Ring
« on: August 30, 2021, 10:37:50 PM »
hi,

I have a partial failure of an LED in the LED Ring (VALUE encoder). Sometimes it comes back sporadically, sometimes this LED stays off. What can i do - Is there any way I can check/measure? Is that a defective LED or is it something else? And if so, where can I get a new LED ring?

Greetings,
rio

2
Atmegatron / Feature: LFO Pre-delay + LFO Attack
« on: August 27, 2021, 11:25:13 AM »
hi,

If someone is interested, I have implemented these two new parameters for the two first potentiometer of the 2nd bank (instead of duplicated filter and Q params). This feature is inspired by what also exists with the NES Chiptune Synthesizer as vibrato attack and vibrato pre-delay to create more a NES sound and is a nice addition to the beloved Atmegatron. Midi support is also included (CC50 LFODLY, CC51 LFOATT) and as an addition a "LFO Sync" option can be set in the configuration using 3rd slot of VALUE dial - so that both parameters are not reset when played notes are not released (default off).

If someone would like to try it out, the modified library is needed and then the SsAtmAtmegatron has to be compiled and uploaded or you take the precompiled binary. The source is based on the last libraries-master branch:

https://github.com/rio-rattenrudel/libraries

Please note:
A. I also fixed the PWM offset, which is used for the "Pulse Width LFO" and fits much better than half a square wave (offset is now HIGH 127 instead MIDDLE 0).

B. You will be amazed that all (or most) of your patches sound strange at first - don't panic. The reason is: The LFO pre-delay and LFO attack values ​​must first be set to 0 for each patch, as the original firmware stores the two filter and Q parameters as duplicates in both banks (green and red). So make sure to take a backup of your patches first before you experiment with this modded firmware ;)

C. I am not sure, maybe all the fun doesn't work properly with arpeggios yet. I'm still looking.


have a nice day & greetings, rio


Edit: Uploaded the final binary here - AtmegatronV2-5.lfo-attack-dly.hex  [2021-08-31]

i have attached a few audio examples (1..7). The pause and/or the transition through the attack to the full LFO portion can be clearly heard. Some examples are also combined with an envelope. Note: The examples are not pure, there is still a tape delay fx in the audio path.

3
Software technical support / Sending debug messages (compile error)
« on: August 25, 2021, 02:56:35 PM »
hi,

is there a way to debug of atmegatron project/librarian source - e.g. via #include <SoftwareSerial.h>, but then i got compile errors: multiple definition of `__vector_3' ..`__vector_5' - a conflict between AtmHardware and SoftwareSerial

.. so is there any other way to debug? or am I doing something wrong in general?

Greetings,
rio

4
Atmegatron / User Waveforms
« on: August 06, 2021, 11:24:21 AM »
hi,

I have a couple of questions about the Librarian and User waveforms:

1. Which user waveforms are pre-installed on the atmegatron? Is it possible to download the currently uploaded waveform of the atmegatron back to the librarian?
2. When I go into user waveform mode and then select waveforms >6 and listen - What is being played for these slots? I can hear different sounds up to patch 15.
3. Will alternative firmware (odytron, atmegadrum etc.) overwrite the user waveform memory?
4. Are Waveforms stored by "easy uploader" backup too?
5. Is there already a newer version of the librarian? the old one actually makes 100% CPU stress in win7 using java8. I know we had discussed this in the past, but it hasn't improved on my WIN7.
6. The picture above shows 0..15 user waveform slots in the Librarian. Is that a bug or unqualified as only 6 patches are allowed?

thank you and greetings, rio

5
As I am still thinking of hanging 2 Atmegatrons directly to 1 FX pedal, I wanted to ask, for example, how high the output impedance of the Atmegatron is.

Can a "T-pad attenuator" be installed in a cable as described here: https://www.rane.com/note109.html?
How high must R1, R2, R3 be calculated in order not to damage the equipment and obtain good signal quality?
The input impedance of the FX device is 1 Mohm.

Thank you and Greetings!

6
Hi paul,

please, can you tell me how high the current consumption (mA) of the Atmegatron/Odytron is? Thanks.

Greetings,
rio

7
Hi paul,

Can you tell me which potentiometer is used for the distortion (which is on the far right)?
That Potentiometer is scratching a bit with me. Maybe I like to replace it.

Is it "Logarithmic" or "Linear"? Please, can you tell me the resistance value, the shaft-height in mm, the type (pin count, identification/product/model number)?
thank you.

Greetings,
rio

8
Odytron / Odytron updates
« on: November 06, 2017, 07:28:51 AM »
Thanks a lot for atmegatron 2.5 update - fantastic!
Is there a chance that an update is pulled for odytron too, for some common features, like prog.change configuration aso.?

Best regards,
rio

9
Software technical support / Compiling Sources - Arduino IDE
« on: October 11, 2017, 01:28:54 PM »
Please, can someone tell me or give me a short advice, which Arduino IDE version can used for recompiling odytron/atmegatron apps with last libraries 2.4? Are there significant changes for both apps in libraries 2.4 (vs 2.1 or 2.3)?

Does the last version ARDUINO 1.8.4 works without any problems?
i know there was the bug within 1.6.6 in the past - and i am afraid what's now working for both correctly.

10
Atmegatron / CC for Volume
« on: October 06, 2017, 12:22:04 PM »
Hi,

i can't see any CC to control volume via CC (normaly #CC 007) . It is technically possible - maybe by modifing code?

Greetings,
rio

11
Atmegatron Librarian / Atmegatron librarian CPU usage
« on: September 28, 2017, 11:34:13 AM »
Hello,

I have noticed that the librarian has a strong cpu load even if the program is only open (idle). Pls, can you analyze/notice the same, is there a fix around this?

- Windows Version -

Greetings,
rio

12
Atmegatron / Program change Feature
« on: April 15, 2016, 11:32:06 PM »
Can you please add the 'program change' midi implementation, so that an external controller can change an atmegatron/odytron patch (1..16) by it's own? Life would be easier ;)

Best regards,
rio

13
Atmegatron / Factory patches
« on: April 11, 2016, 10:19:43 PM »
hey,

it's quite difficult to me to get the original patches of atmegatron or/and odytron on the machine back. is there any *.mem factory file? and are the internal patches changed from the version upgrades... it seems some patches complete different and some patches aren't playing.

greetings, rio

Pages: [1]