Author Topic: Compiling Error: OSX - Arduino 1.6.7 - SSAtmAtmegatron.ino  (Read 1465 times)

Compiling Error: OSX - Arduino 1.6.7 - SSAtmAtmegatron.ino

« on: February 20, 2016, 11:03:19 PM »
Open quickbuttons

georgecoller

Posts: 1

Offline
  • *
  • Newbie
    • View Profile
Got my new Odytron edition and loving it but am getting compiling errors when trying to get the original SSAtmAtmegatron.ino to work (see below).  the clycotron, delayertron, and odytron files compile and upload fine.

Arduino: 1.6.7 (Mac OS X), Board: "Arduino/Genuino Uno"

In file included from sketch/SsAtmAtmegatron.ino.cpp:1:0:
/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/cores/arduino/Arduino.h:40:14: error: expected unqualified-id before numeric constant
 #define HIGH 0x1
              ^
/Users/georgecoller/Documents/Arduino/libraries/AtmPatch/AtmPatch.h:52:29: note: in expansion of macro 'HIGH'
  static const unsigned char HIGH = 1;

                             ^
/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/cores/arduino/Arduino.h:41:14: error: expected unqualified-id before numeric constant
 #define LOW  0x0
              ^
/Users/georgecoller/Documents/Arduino/libraries/AtmPatch/AtmPatch.h:53:29: note: in expansion of macro 'LOW'
  static const unsigned char LOW = 0;

                             ^
/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/cores/arduino/Arduino.h:40:14: error: expected unqualified-id before numeric constant
 #define HIGH 0x1
              ^
/Users/georgecoller/Documents/Arduino/libraries/AtmEngine/AtmEngine.h:114:29: note: in expansion of macro 'HIGH'
  static const unsigned char HIGH = 1;

                             ^
/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/cores/arduino/Arduino.h:41:14: error: expected unqualified-id before numeric constant
 #define LOW  0x0
              ^
/Users/georgecoller/Documents/Arduino/libraries/AtmEngine/AtmEngine.h:115:29: note: in expansion of macro 'LOW'
  static const unsigned char LOW = 0;

                             ^
exit status 1
Error compiling.

  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.

Re: Compiling Error: OSX - Arduino 1.6.7 - SSAtmAtmegatron.ino

« Reply #1 on: February 21, 2016, 09:51:24 PM »
Open quickbuttons

paulsoulsby

Posts: 171

Offline
  • Administrator
  • *****
  • Full Member
    • View Profile
Hi,
The libraries are currently only compatible with Arduino 1.6.5.  Arduino and Atmel Studio are in a bit of a transitional phase at the moment.  I will update the libraries to the latest version when things have settled a bit.  You can get 1.6.5 from here: https://www.arduino.cc/en/Main/OldSoftwareReleases#previous