Author Topic: EasyUpLoader  (Read 98 times)

EasyUpLoader

« on: June 09, 2018, 03:08:31 PM »
Open quickbuttons

arpeggio

Posts: 1

Offline
  • *
  • Newbie
    • View Profile
   Hello, i got the tip for the EasyUpLoader from Jean-luc Delariere, i have some boards from him and i will maybe buy an Atmegatron or something, i spotted these great synths already, but you know how it goes, anyway,
i much like the tweakability of it, i do a lot with Arduino so i will look into it again.
My question is about the easyuploader, because i am making, coding and selling on Tindie my Ipeggio, it's on sound/MIDI tab, Newest and then you find Ipeggio.
And if i want to update firmware for the users i can send the firmware and with the Easyuploader the user can upload the firmware to the Arduino Mega and
Then he/she does not see the code, and only use the Hex-file.   Like you probably do and Jean-luc does.
So i tryed using the easyuploader, works great for an Uno, but for the Mega it says avrdude getsync() not in sync.     On Windows 7.
I had all the settings good i guess, cause it is connecting and trying to upload, the board resets and then gets two or three transmitted messages, i see the RX led lit up,
and then no good TX responce from the Mega, Avrdude says not in sync, i tryed lowering the bautrate, no result..
I also tryed XLoader and the same no result, Does anyone have a qlue to get me going with this one, any  help is welcome.
Thanks in advance, Dian From the Netherlands

Re: EasyUpLoader

« Reply #1 on: June 11, 2018, 11:44:09 AM »
Open quickbuttons

paulsoulsby

Posts: 215

Offline
  • Administrator
  • *****
  • Full Member
    • View Profile
You're using an Atmega328P ?  It should work fine for that, but not for any other Atmega.  This is because I have hard-coded the Atmega328P into the AVRDUDE command in the software.
Also, you should have a cap (think 0.1uF) in series with the reset line in your schematic.  Do you have this?