Author Topic: Build problems. Fried board?  (Read 88 times)

Build problems. Fried board?

« on: July 03, 2018, 12:53:43 AM »
Open quickbuttons

CatizenSnaps

Posts: 1

Offline
  • *
  • Newbie
    • View Profile
Hello folks,

I recently sat down and put together a mini-Atmegatron kit and, upon completion, have found that it's completely functionless, won't power up at all. During the build, I had to desolder and refit one capacitor, and I fear I may have overheated and fried the board in the process - the metal circuit bit on the PCB peeled off slightly and I had a tough time getting the solder to stick again. I also had a little difficulty soldering the LEDs and I think I've bridged the three pins on one of them - I have a yet to correct this as I'm a little wary of desoldering following the prior problem. Is there anything I can do to try to fix it or is it likely that the board is irreparably damaged? If so, is there any way that I can purchase just a new board without the rest of the kit - the components and Arduino all seem fine. I've attached some pictures of the board for illustration. Still getting the hang of soldering and this is my first kit build, so please bear with me if this is more obvious than it seems. All feedback greatly appreciated!

Re: Build problems. Fried board?

« Reply #1 on: July 05, 2018, 10:49:57 AM »
Open quickbuttons

paulsoulsby

Posts: 215

Offline
  • Administrator
  • *****
  • Full Member
    • View Profile
Hi - what temperature did you have your soldering iron on?  As long as it wasn't on mega-hot mode, I'm sure the board will be fine.
R.e. the capacitor you replaced:  if the metal pads have been totally destroyed, you will need to use bits of wire to attach the cap to the traces.  Which cap was it that you replaced?
R.e. the LEDs.  Nearly all these pins are bridged!  I recommend buying some desoldering braid to remove the excess solder. There must not be any contact between the pads.
Also, there's no header in CONN4!  Don't forget to put this in - it won't work without it!